Repository navigation
fix: require Python 3.10 and complete the PyPI metadata - #73
Merged
Merged
Conversation
Add the PyPI install command to both READMEs, raise requires-python to 3.10 (3.8 and 3.9 are EOL and neither is tested), and list the tested 3.13 and 3.14 classifiers. Update the stale comment about Python 3.8.
|
🎉 This PR is included in version 1.1.3 🎉 The release is available on GitHub release Your semantic-release bot 📦🚀 |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Summary
Complete the litegrip PyPI page and align the declared Python support with what CI actually tests. The PyPI install command comes first,
requires-pythonbecomes>=3.10, and the classifiers now cover the tested 3.13 and 3.14.Changes
pip install litegrip-pythonfirst; the checkout install stays as the alternative.requires-python = ">=3.10"; classifiers 3.10–3.14 (3.13 and 3.14 added, 3.8 and 3.9 removed).tests/test_calibration.py.Testing
Result:
Ran 467 tests in 10.652s—OK.Built a wheel and checked the metadata:
Requires-Python: >=3.10, classifiers for 3.10–3.14,License-Expression: Apache-2.0, and the twoProject-URLentries.twine check /tmp/litegrip-meta/*.whl→ PASSED.Issues
No linked issue.