You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
{{ message }}
This repository was archived by the owner on Feb 26, 2024. It is now read-only.
Repository navigation
This repository was archived by the owner on Feb 26, 2024. It is now read-only.
Reacted by Marco Garbelini, songchangyou, Mo, Fábio Paiva, Evgeni Dimitrov, José Henrique Kracik da Silva, JetPack Data, Abdul Aleem, ryan dushane, Fedor Belov and 16 more
Reacted by Afsal K, Mohamed Aboelmagd, barbielee, Ansuman Nayak and webapricot
Thanks for the help.
I updated to the latest node, it need can skip this issue.
I saw the major version for node (official site) is still 4.4.6, which also have this issue.
reason seems the angular2-in-memory-web-api@0.0.12 wants @angular/core@2.0.0-rc.2
but core is already 3.
guess still better have a fix on it?
I'm having the same issue when trying to deploy to AWS which uses node 4.4.3 (npm 2.15.1) , is there any way around this or am I stuck until a fix is in place?
I found something awesome in regards to node
anything you have a problem with just uninstall and reinstall it and then reinstall any dependencies they might require!
Activity
timz commentedon Jun 17, 2016
update npm:
npm install npm -g
chore: update in-mem-api version
chore: update in-mem-api version (#136)
filipesilva commentedon Jun 17, 2016
Sorry, one of the dependencies was left in a old one. It should be fixed now.
ygmgbg commentedon Jun 18, 2016
thank you
airhork commentedon Jun 27, 2016
@filipesilva
seems this issue happens again?
npm ERR! node v0.12.0
npm ERR! npm v2.5.1
npm ERR! code EPEERINVALID
npm ERR! peerinvalid The package @angular/core does not satisfy its siblings' pe
erDependencies requirements!
npm ERR! peerinvalid Peer @angular/common@2.0.0-rc.3 wants @angular/core@2.0.0-r
c.3
npm ERR! peerinvalid Peer @angular/compiler@2.0.0-rc.3 wants @angular/core@2.0.0
-rc.3
npm ERR! peerinvalid Peer @angular/forms@0.1.1 wants @angular/core@2.0.0-rc.3
npm ERR! peerinvalid Peer @angular/http@2.0.0-rc.3 wants @angular/core@2.0.0-rc.
3
npm ERR! peerinvalid Peer @angular/platform-browser@2.0.0-rc.3 wants @angular/co
re@2.0.0-rc.3
npm ERR! peerinvalid Peer @angular/platform-browser-dynamic@2.0.0-rc.3 wants @an
gular/core@2.0.0-rc.3
npm ERR! peerinvalid Peer @angular/router@3.0.0-alpha.8 wants @angular/core@^2.0
.0-rc.2
npm ERR! peerinvalid Peer @angular/router-deprecated@2.0.0-rc.2 wants @angular/c
ore@^2.0.0-rc
npm ERR! peerinvalid Peer @angular/upgrade@2.0.0-rc.3 wants @angular/core@2.0.0-
rc.3
npm ERR! peerinvalid Peer angular2-in-memory-web-api@0.0.12 wants @angular/core@
2.0.0-rc.2
Foxandxss commentedon Jun 27, 2016
That node is reaaaaaaaaaally old.
airhork commentedon Jun 27, 2016
indeed, it probably an old node
but I assume the error is because of the upgrade from 2.0.0-rc.2 to 2.0.0-rc.
3? No
filipesilva commentedon Jun 27, 2016
@airhork I think it's actually because of node, I know that similar peerDeps issues are solved on newer versions. Can you try node 5 or 6?
Foxandxss commentedon Jun 27, 2016
Is NPM probably the problematic one, but I recommend Node 5 at least.
airhork commentedon Jun 27, 2016
ok, thanks for the quick feedback. installing.
airhork commentedon Jun 27, 2016
Thanks for the help.
I updated to the latest node, it need can skip this issue.
I saw the major version for node (official site) is still 4.4.6, which also have this issue.
reason seems the angular2-in-memory-web-api@0.0.12 wants @angular/core@2.0.0-rc.2
but core is already 3.
guess still better have a fix on it?
Foxandxss commentedon Jun 27, 2016
That is expected and will be fixed soon. Still with that, it should work.
JessRascal commentedon Jun 27, 2016
I'm having the same issue when trying to deploy to AWS which uses node 4.4.3 (npm 2.15.1) , is there any way around this or am I stuck until a fix is in place?
Foxandxss commentedon Jun 27, 2016
I am not really sure if a solution for npm 2.x is going to come.
Can't it be updated to latest npm?
npm i -g npmcooervo commentedon Aug 4, 2016
Hi there I'm on node v5.10.0 and after trying
meteor npm install --save angular2-meteorI get the same error:The package @angular/commmon@2.0.0-rc.4 does not satisfy its siblings' peerDependencies requirements!I already tried
npm install npm -gas suggested above andnpm install angular2filipesilva commentedon Aug 10, 2016
@cooervo you'll have to ask at the
angular2-meteorrepo. We don't control the dependencies they use.pashaproton commentedon Aug 26, 2016
Guys, I had the same error. For me helps
npm i -g npmmxfp0 commentedon Sep 16, 2016
Update npm (npm install npm -g) solved for me!
madrahimov commentedon Sep 23, 2016
Thanks you !!! (npm install npm -g) solved my issue also
emaalouf commentedon Apr 29, 2017
I found something awesome in regards to node
anything you have a problem with just uninstall and reinstall it and then reinstall any dependencies they might require!