You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
{{ message }}
Repository navigation
The upgrade guide does not cover ng update stopping on a Node.js version message #3786
In an app that is already on Angular 21, ng update @angular/fire@next can stop before it updates anything:
Installing a temporary Angular CLI versioned latest to perform the update.
Node.js version v22.22.1 detected.
The Angular CLI requires a minimum Node.js version of v22.22.3 or v24.15.0 or v26.0.0.
Node.js 22.22.1 is a version Angular 21 supports, so the message is confusing, and docs/version-21-upgrade.md does not mention it.
Why it happens
ng update chooses which Angular CLI runs the update from the first @angular/ package in the command. If that package has no version number, it downloads @angular/cli@latest.
@angular/cli@latest is 22.2.1, which requires Node.js ^22.22.3 || ^24.15.0 || >=26.0.0. Angular CLI 21 accepts ^20.19.0 || ^22.12.0 || >=24.0.0.
On a Node.js version in between, the downloaded CLI refuses to start. This is Angular CLI behavior, and it happens before any AngularFire code runs.
What I ran
On Node.js 22.22.1, on 2026-10-02:
ng update @angular/fire and ng update @angular/fire@next in an Angular 21 app both stop with the message above.
ng update @angular/fire@21.0.0-rc.1 in the same app does not.
The guide's own command, ng update @angular/core@21 @angular/cli@21 @angular/fire@next, is not affected. It ran with a temporary Angular CLI 21.2.24 and completed.
Proposed change
A bullet under "Other notes" naming the message, the cause, and the two ways past it: update Node.js, or give the first @angular/ package a version number.
Activity
docs: cover ng update stopping on a Node.js version message (angular#…